环境安装
This documentation is for an out-of-date version of Apache Flink. We recommend you use the latest stable version.

环境安装 #

环境要求 #

注意 PyFlink 需要 Python 3.6 以上版本(3.6, 3.7 或 3.8)。请运行以下命令,以确保 Python 版本满足要求。

$ python --version
# the version printed here must be 3.6, 3.7 or 3.8

环境设置 #

你的系统也许安装了好几个版本的 Python。你可以运行下面的 ls 命令来查看当前系统中安装的 Python 版本有哪些:

$ ls /usr/bin/python*

为了满足 Python 版本要求,你可以选择通过软链接的方式将 python 指向 python3 解释器:

ln -s /usr/bin/python3 python

除了软链接的方式,你也可以选择创建一个 Python virtual env(venv)的方式。关于如何创建一个 virtual env,你可以参考准备 Python 虚拟环境

如果你不想使用软链接的方式改变系统 Python 解释器的路径,你也可以通过配置的方式指定 Python 解释器。 你可以参考配置python.client.executable,了解如何指定编译作业时所使用的 Python 解释器路径, 以及参考配置python.executable,了解如何指定执行 Python UDF 时所使用的 Python 解释器路径。

PyFlink 已经被发布到PyPi,可以通过如下方式安装 PyFlink:

$ python -m pip install apache-flink==1.13.3

你也可以从源码手动构建 PyFlink,具体可以参见开发指南.

注意 从Flink 1.11版本开始, PyFlink 作业支持在 Windows 系统上运行,因此您也可以在 Windows 上开发和调试 PyFlink 作业了。